Back to overview
Downtime
Storage Box connection issues
Apr 8, 2026 at 10:39am UTC
Affected services
Storage Box
Resolved
Apr 9, 2026 at 5:42am UTC
The issue has been resolved.
Affected services
Created
Apr 8, 2026 at 10:39am UTC
We are currently facing a storage issue with our storage box servers.
Affected services